$re = '/([0-9]{2,4}[\-|\\\\][0-9]{1,2}[\-|\\\\][0-9]{2,4})/is';
$str = '02-01-2012';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);