import re
regex = re.compile(r"([0-9]{2,4}[\-|\\][0-9]{1,2}[\-|\\][0-9]{2,4})", flags=re.IGNORECASE | re.DOTALL)
test_str = "02-01-2012"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")