use strict;
my $str = 'papave23 ciao il mio pin papaver1 è reeredji332ji con vaff8loe 1234567o 123t123t papavero 9o 123t123y';
my $regex = qr/\b(?=(?:[0-9]*[a-zA-Z]){2})(?=(?:[a-zA-Z]*[0-9]){2})[a-zA-Z0-9]{8}\b/p;
my $subst = '********';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";