import Foundation
let pattern = #"\b(?=(?:[0-9]*[a-zA-Z]){2})(?=(?:[a-zA-Z]*[0-9]){2})[a-zA-Z0-9]{8}\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"papave23 ciao il mio pin papaver1 è reeredji332ji con vaff8loe 1234567o 123t123t papavero 9o 123t123y"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"********"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)