package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`These\s+are\s+my\s+variables((?:\s*-\w+\s+\$\w+)*)\s+for\s+(case\d)`)
var str = `These are my variables -abc $def -geh $ijk for case1
These are my variables -lmn $opq -rst $uvw for case2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}