$re = '/These\s+are\s+my\s+variables((?:\s*-\w+\s+\$\w+)*)\s+for\s+(case\d)/';
$str = 'These are my variables -abc $def -geh $ijk for case1
These are my variables -lmn $opq -rst $uvw for case2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);