import re
regex = re.compile(r"(201[0-9]-[0-9][0-9]-[0-9][0-9])(?=.*?((?i)-Test-))", flags=re.MULTILINE)
test_str = ("2015-12-29-Test-Rechnungskopie.pdf\n"
"2016-12-29-Test-Prämienrechung\n"
"2015-01-20-Test-Leistungsabrechnung.pdf")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")