#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<table[^>]*id="table_id2">((?:\s*<tr[^>]*><td>[^>]*<\/td><\/tr>\s*)+)"
Local $sString = "<table class="my_table" id="table_id1">" & @CRLF & _
" <tr class="odd"><td>Line 1</td></tr>" & @CRLF & _
" <tr class="even"><td>Line 2</td></tr>" & @CRLF & _
" <tr class="odd"><td>Line 3</td></tr>" & @CRLF & _
" <tr class="even"><td>Line 4</td></tr>" & @CRLF & _
"</table>" & @CRLF & _
"<table class="my_table" id="table_id2">" & @CRLF & _
" <tr class="odd"><td>Line 1</td></tr>" & @CRLF & _
" <tr class="even"><td>Line 2</td></tr>" & @CRLF & _
" <tr class="odd"><td>Line 3</td></tr>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")