$re = '/(?<key>\w+)\s*=\s*([\'"]?)(?<val>(?:(?!\2)[^\\\\]|\\\\.|\w)*)\2/';
$str = 'name = bar,
name = "bar",
name = \'bar\',
name = "\\"ba\\"r\\"",
name = \'\',
name = ,
name = bar,
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);