re = /(?<key>\w+)\s*=\s*(['"]?)(?<val>(?:(?!\2)[^\\]|\\.|\w)*)\2/
str = 'name = bar,
name = "bar",
name = \'bar\',
name = "\\"ba\\"r\\"",
name = \'\',
name = ,
name = bar,
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end