package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{2,}):(\d{2}):(\d{2,}):(\d{2,}\.?\d*)$`)
var str = `11:22:33
11:22:33:44
11:22:33:444.4444
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}