re = /^(\d{2,}):(\d{2}):(\d{2,}):(\d{2,}\.?\d*)$/m
str = '11:22:33
11:22:33:44
11:22:33:444.4444
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end