using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*index[.]php[?]?";
string input = @"http://localhost/esculape/www/index.php?a=10
http://localhost/esculape/www/index.php";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}