$re = '/.*index[.]php[?]?/';
$str = 'http://localhost/esculape/www/index.php?a=10
http://localhost/esculape/www/index.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);