$re = '/(\$[a-z]{1})(.*?)(?=\$|$)/';
$str = '10$athis is text a$bthis is text b/$cthis is text$dthis is text d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);