re = /(\$[a-z]{1})(.*?)(?=\$|$)/
str = '10$athis is text a$bthis is text b/$cthis is text$dthis is text d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end