package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div\s+class="price-display\s+csTile-price">\s+<span\s+class="sup">\$<\/span>\s+(\d+)\s+`)
var str = `<div class="price-display csTile-price">
<span class="sup">$</span>
299
<span class="currency-delimiter">.</span>
<span class="sup">00</span>
</div>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}