import Foundation
let pattern = #"<div\s+class="price-display\s+csTile-price">\s+<span\s+class="sup">\$<\/span>\s+(\d+)\s+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div class="price-display csTile-price">
<span class="sup">$</span>
299
<span class="currency-delimiter">.</span>
<span class="sup">00</span>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}