$re = '/(?<partbeingcaptured>\-\s*\((?<RetType>.*?)\)\s*)(?<FuncName>(\w+))\s*{/';
$str = '-(void) heyzapCheckinTapped: (id)sender {';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);