$re = '/(?<!=|= )\$[^\"\' \|\[]+?;/';
$str = '$get.q.htmlentities();
var val = $(this).val();
var val2 = $().val();';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);