re = /(?<!=|= )\$[^\"' \|\[]+?;/
str = '$get.q.htmlentities();
var val = $(this).val();
var val2 = $().val();'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end