#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(string1.+?)(?:'string2)"
Local $sString = "['string1','string2','string3']" & @CRLF & _
"['string1' , 'string2' , 'string3']" & @CRLF & _
"['string1.domain.com' , 'string2.domain.com' , 'string3.domain.com']" & @CRLF & _
"['string1.domain.com:8080' , 'string2.domain.com:8080' , 'string3.domain.com:8080']"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")