package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(string1.+?)(?:'string2)`)
var str = `['string1','string2','string3']
['string1' , 'string2' , 'string3']
['string1.domain.com' , 'string2.domain.com' , 'string3.domain.com']
['string1.domain.com:8080' , 'string2.domain.com:8080' , 'string3.domain.com:8080']`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}