package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`_[A-Z]+(\d+(\.\d+)?)`)
var str = `fname <-'FS1_SCN0.83_axg3.csv'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}