$re = '/_[A-Z]+(\d+(\.\d+)?)/';
$str = 'fname <-\'FS1_SCN0.83_axg3.csv\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);