$re = '/^(?=.{5,6}$)[a-zA-Z0-9]+(?:-[a-zA-Z0-9]+)*$/m';
$str = 'safety
safet-
saft-gggdgdhgdh
-sad
s0g-hg
s-a-fe
saft-g
sag--g
-shgh-
s-df-f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);