import re
regex = re.compile(r"^(?=.{5,6}$)[a-zA-Z0-9]+(?:-[a-zA-Z0-9]+)*$", flags=re.MULTILINE)
test_str = ("safety\n"
"safet-\n"
"saft-gggdgdhgdh\n"
"-sad\n"
"s0g-hg\n"
"s-a-fe\n"
"saft-g\n"
"sag--g\n"
"-shgh-\n"
"s-df-f")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")