#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?<=<!-- emailFooter START -->).*"
Local $sString = "some text" & @CRLF & _
"before the footer and" & @CRLF & _
"<!-- emailFooter START -->then here's" & @CRLF & _
"even" & @CRLF & _
"more text" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")