$re = '/(?<=<!-- emailFooter START -->).*/ms';
$str = 'some text
before the footer and
<!-- emailFooter START -->then here\'s
even
more text
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);