const regex = /<h1>(.*)<\/h1>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<h1>(.*)<\\\/h1>', '')
const str = `<div id="test"><h1>hello world</h1></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}