$re = '/<h1>(.*)<\/h1>/';
$str = '<div id="test"><h1>hello world</h1></div>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);