import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([CDEFGAB](#|##|b|bb)?)((M|m|aug|dim|sus|add)?(6|7|9|11|13|-5|\\+5)?)";
final String string = "Bm7 E7 E/A F#m7 Bm7\n"
+ "어두운 밤 골목길을 혼자 털레털레 오르다 c 올라\n"
+ "Bm7 E7 E/A F#m7\n"
+ "지나가는 네 생각에 내가 눈물이 난 게 아니고\n"
+ " Bm7 E7 C#m7 F#7\n"
+ "이부자리를 치우다 너의 양말 한 짝이 나와서\n"
+ " Bm7 E7 C#m7 F#7\n"
+ "갈아 신던 그 모습이 내가 그리워져 운 게 아니고\n"
+ " Bm7 E7 E/A F#m7\n"
+ "보일러가 고장 나서 울지";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}