use strict;
my $str = 'Bm7 E7 E/A F#m7 Bm7
어두운 밤 골목길을 혼자 털레털레 오르다 c 올라
Bm7 E7 E/A F#m7
지나가는 네 생각에 내가 눈물이 난 게 아니고
Bm7 E7 C#m7 F#7
이부자리를 치우다 너의 양말 한 짝이 나와서
Bm7 E7 C#m7 F#7
갈아 신던 그 모습이 내가 그리워져 운 게 아니고
Bm7 E7 E/A F#m7
보일러가 고장 나서 울지';
my $regex = qr/([CDEFGAB](#|##|b|bb)?)((M|m|aug|dim|sus|add)?(6|7|9|11|13|-5|\+5)?)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}