using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"T\d[NMXab\d]*(?!D)";
string input = @"Jotkin tekstinlouhintaongelmista on yksiselitteisiä ratkaista. Otetaan esimerkkinä syövän kokoa ja levinneisyyttä kuvaava TNM-luokitus. TNM-data on useimmissa syöpätutkimusprojekteissa relevattia ja haluttua kliinistä tietoa, sillä se kertoo tutkijalle syövän vakavuudesta. Esimerkiksi ”T4N1M0”-luokitellusta kasvainnäytteestä tutkija voisi päätellä, että näytteenantajan alkuperäinen syöpäkasvain on suuri ja levinnyt lähi-imusolmukkeisiin, muttei ole vielä lähettänyt etäpesäkkeitä muualle näytteenantajan elimistöön (muita usein esiintyviä TNM-tapauksia ovat mm. ”T2NX”, ”T4aM1”, ”T1bN0MX” muttei esimerkiksi ”T2DM”, joka on lyhenne tyypin 2 diabeteksesta). Mainittakoon, että yli puolet Aurian biopankkitutkimuksista liittyy syöpään, joten kysymys TNM-luokan selvittämisestä on todellakin usein toistuva. Aina tieto kasvaimen TNM-luokasta ei kuitenkaan ole rakenteellisesti saatavilla, joten tietoa on louhittava esimerkiksi patologin lausunnoista: yllä mainitut validit TNM-luokat olisivat saatu melko yksinkertaisella regex-haulla ” T\d[NMXab\d]*(?!D)” kiinni ( DEMO ).";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}