use strict;
my $str = 'Jotkin tekstinlouhintaongelmista on yksiselitteisiä ratkaista. Otetaan esimerkkinä syövän kokoa ja levinneisyyttä kuvaava TNM-luokitus. TNM-data on useimmissa syöpätutkimusprojekteissa relevattia ja haluttua kliinistä tietoa, sillä se kertoo tutkijalle syövän vakavuudesta. Esimerkiksi ”T4N1M0”-luokitellusta kasvainnäytteestä tutkija voisi päätellä, että näytteenantajan alkuperäinen syöpäkasvain on suuri ja levinnyt lähi-imusolmukkeisiin, muttei ole vielä lähettänyt etäpesäkkeitä muualle näytteenantajan elimistöön (muita usein esiintyviä TNM-tapauksia ovat mm. ”T2NX”, ”T4aM1”, ”T1bN0MX” muttei esimerkiksi ”T2DM”, joka on lyhenne tyypin 2 diabeteksesta). Mainittakoon, että yli puolet Aurian biopankkitutkimuksista liittyy syöpään, joten kysymys TNM-luokan selvittämisestä on todellakin usein toistuva. Aina tieto kasvaimen TNM-luokasta ei kuitenkaan ole rakenteellisesti saatavilla, joten tietoa on louhittava esimerkiksi patologin lausunnoista: yllä mainitut validit TNM-luokat olisivat saatu melko yksinkertaisella regex-haulla ” T\\d[NMXab\\d]*(?!D)” kiinni ( DEMO ).';
my $regex = qr/T\d[NMXab\d]*(?!D)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}