$re = '/(?<=[\s<])\w{3}/m';
$str = '"From: XXX YYY <ZZZ>"
"From: XXX <ZZZ>"
"From: ZZZ"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);