re = /(?<=[\s<])\w{3}/m
str = '"From: XXX YYY <ZZZ>"
"From: XXX <ZZZ>"
"From: ZZZ"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end