#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*(\b\w+#\d+)[^{]*{.*{ *([^}]*?) *}.*$"
Local $sString = "" & @CRLF & _
"net trunk trunk#1 { bandwidth 20000 cfg-mbr-count 2 id 0 interfaces { 2.1 2.2 } lacp enabled" & @CRLF & _
"" & @CRLF & _
"net trunk trunk#2 { bandwidth 4000 cfg-mbr-count 2 id 0 interfaces { 1.1 1.2 1.3 1.4 } lacp enabled" & @CRLF & _
"" & @CRLF & _
"net trunk chocolatesilk#314 { bandwidth 4000 cfg-mbr-count 2 id 0 interfaces { 3.14.15.92 65.35.89.79 } lacp enabled" & @CRLF & _
"" & @CRLF & _
"net trunk edisthestandardtexteditor#237 { bandwidth 4000 cfg-mbr-count 2 id 0 interfaces { 101.100.105.116 116.101.120.116 } lacp enabled" & @CRLF & _
""
Local $sSubst = "$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)