$re = '/^.*(\b\w+#\d+)[^{]*{.*{ *([^}]*?) *}.*$/m';
$str = '
net trunk trunk#1 { bandwidth 20000 cfg-mbr-count 2 id 0 interfaces { 2.1 2.2 } lacp enabled
net trunk trunk#2 { bandwidth 4000 cfg-mbr-count 2 id 0 interfaces { 1.1 1.2 1.3 1.4 } lacp enabled
net trunk chocolatesilk#314 { bandwidth 4000 cfg-mbr-count 2 id 0 interfaces { 3.14.15.92 65.35.89.79 } lacp enabled
net trunk edisthestandardtexteditor#237 { bandwidth 4000 cfg-mbr-count 2 id 0 interfaces { 101.100.105.116 116.101.120.116 } lacp enabled
';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;