# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=var)(((\s+[\$\w]+[^\n{]*);)(\s+)var)(\s*)(?=(?2))/\3,\4 /g;t' <<< "{
var $jqueryFoo = 'foo';
var bar = 'bar';
}
{
var foo = require('/foo');
var bar = require('/bar');
var foobar = require('/foobar');
}
{
var foo = 'foo';
var bar = 'bar';
var baz;
}
{
var foo = 'foo';
var bar = 'bar';
BAZ = 'baz';
}
{
var foo = 'foo';
var bar = 'bar';
var obj = {
foo: 'foo',
bar: 'bar'
};
}"