const regex = /([-\d.]+),([-\d.]+),?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([-\\d.]+),([-\\d.]+),?', 'g')
const str = `38.313072,-89.863845,38.312675,-89.863586,38.310405,-89.862091,38.310405,-89.862091,38.309913,-89.861976,38.309768,-89.861976,38.309768,-89.861976
`;
const subst = `[$1, $2]\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);