import re
regex = re.compile(r"([-\d.]+),([-\d.]+),?")
test_str = ("38.313072,-89.863845,38.312675,-89.863586,38.310405,-89.862091,38.310405,-89.862091,38.309913,-89.861976,38.309768,-89.861976,38.309768,-89.861976\n")
subst = "[$1, $2]\\n"
result = regex.sub(subst, test_str)
if result:
print(result)