$re = '/\bUse\b[ \t]+[a-zA-Z0-9_\[\]]+/i';
$str = 'fgf USE [MarketWorkFlowDb] dfhdjfh
GO use
IF EXISTS (SELECT * FROM sys.objects WHERE object_id = OBJECT_ID(N\'[dbo].[DeleteLkpDataSp]\') AND type in (N\'P\', N\'PC\'))
DROP PROCEDURE [dbo].[DeleteLkpDataSp]
GO';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);