// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\bUse\b[ \t]+[a-zA-Z0-9_\[\]]+").unwrap();
let string = "fgf USE [MarketWorkFlowDb] dfhdjfh
GO use
IF EXISTS (SELECT * FROM sys.objects WHERE object_id = OBJECT_ID(N'[dbo].[DeleteLkpDataSp]') AND type in (N'P', N'PC'))
DROP PROCEDURE [dbo].[DeleteLkpDataSp]
GO";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}