#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "string name="(.*)">[^%1\n]*<"
Local $sString = "<!-- Reply to message -->" & @CRLF & _
" <string name="mail_author_wrote">%1$s wrote…</string>" & @CRLF & _
" <string name="mail_hint_recipient">Recipient</string>" & @CRLF & _
" <string name="mail_hint_subject">Subject</string>" & @CRLF & _
" <string name="mail_hint_body">Body</string>" & @CRLF & _
" <string name="mail_send_to">"Send a message to %1$s"</string>" & @CRLF & _
" <string name="mail_send">Send a message</string>" & @CRLF & _
" <string name="mail_notification_msg">New message from</string>" & @CRLF & _
" <string name="mail_reply_to">Reply to %1$s</string>" & @CRLF & _
" <string name="mail_notification_author">from</string>" & @CRLF & _
" <string name="mail_theirs">View their message</string>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")