import re
regex = re.compile(r"string name=\"(.*)\">[^%1\n]*<")
test_str = ("<!-- Reply to message -->\n"
" <string name=\"mail_author_wrote\">%1$s wrote…</string>\n"
" <string name=\"mail_hint_recipient\">Recipient</string>\n"
" <string name=\"mail_hint_subject\">Subject</string>\n"
" <string name=\"mail_hint_body\">Body</string>\n"
" <string name=\"mail_send_to\">\"Send a message to %1$s\"</string>\n"
" <string name=\"mail_send\">Send a message</string>\n"
" <string name=\"mail_notification_msg\">New message from</string>\n"
" <string name=\"mail_reply_to\">Reply to %1$s</string>\n"
" <string name=\"mail_notification_author\">from</string>\n"
" <string name=\"mail_theirs\">View their message</string>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")