package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\S*\s*\S*\s*\S*\*)(.*)`)
var str = `asdas sdfsd sdfs sdfs sdfsdf sdf
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}