$re = '/(\S*\s*\S*\s*\S*\*)(.*)/';
$str = 'asdas sdfsd sdfs sdfs sdfsdf sdf
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);