package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)v=([^\s&]*)`)
var str = `https://m.youtube.com/watch?v=9tg3csrFVJw&foo=bar&bar=foo
https://m.youtube.com/watch?foo=bar&bar=foo&v=9tg3csrFVJw`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}