$re = '/v=([^\s&]*)/m';
$str = 'https://m.youtube.com/watch?v=9tg3csrFVJw&foo=bar&bar=foo
https://m.youtube.com/watch?foo=bar&bar=foo&v=9tg3csrFVJw';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);